Welcome, Guest
Username: Password: Remember me
  • Page:
  • 1
  • 2

TOPIC: Set parameters based on physical key being pressed

Set parameters based on physical key being pressed 2 months 1 day ago #1

  • batata004
  • batata004's Avatar
  • Offline
  • New Member
  • Posts: 15
  • Thank you received: 1
Hi,

I am using Polyphone and it's freaking amazing and all the "problems" I had, I managed (with help of the community) to fix. But now I have a new "problem" and I would like to know if this has a solution: sometimes I set some samples to play only from C3 to C6 in my piano (just an example). If I press the physical key C6 on my piano, everything works as expected, I mean: the expected sound plays nicely.

However if I set my piano to tranpose +2 semi tones, when I press the physical key C6 on my piano, the expected sound does not play. Of course, because of the transpositiong, the C6 is now actually D6. However sometimes I really need to set samples based on physical keys being pressed (despite using any transposition)... is there any way to do this?
Last Edit: 2 months 1 day ago by batata004.
The administrator has disabled public write access.

Set parameters based on physical key being pressed 2 months 1 day ago #2

  • csw900
  • csw900's Avatar
  • Offline
  • Senior Member
  • Posts: 59
  • Thank you received: 13
Hi batata004

If your physical piano keys are transposed before they get to polyphone then how is pokyphone going to know which physical key was pressed? Polyphone will see only the transposed key!!

Why dont you extend the range of your samples to accommodate the transposition?

csw900
csw900
The administrator has disabled public write access.

Set parameters based on physical key being pressed 2 months 1 day ago #3

  • batata004
  • batata004's Avatar
  • Offline
  • New Member
  • Posts: 15
  • Thank you received: 1
Hi!

I thought that the transposition information was sent in the MIDI cable along with the keys being pressed... But, as I understand from you, my piano only sends the keys being pressed already being transposed, right? If that's the case, then you are right, it would be impossible to do what I need.

I cant increase the range of the keys because in some songs, I always want to make sure I will only press keys from C3 and C6 (no matter the tranposition), outside of that range the sound that will play will be effects (like drums, applause...). Between C3 and C6 will be piano sound.
The administrator has disabled public write access.

Set parameters based on physical key being pressed 2 months 20 hours ago #4

  • csw900
  • csw900's Avatar
  • Offline
  • Senior Member
  • Posts: 59
  • Thank you received: 13
Hi batata004

Yes i confirm that a midi piano does not send any transposition information along with the notes. Midi has no capability in this area.

csw900
csw900
The administrator has disabled public write access.
The following user(s) said Thank You: batata004

Set parameters based on physical key being pressed 2 months 20 hours ago #5

  • batata004
  • batata004's Avatar
  • Offline
  • New Member
  • Posts: 15
  • Thank you received: 1
That's really sad! That's the first thing I found soundfont cant handle! In most keyboards, the user can always set a split function to split its keyboard in specific areas/regions so the user can attach specific sounds to each area. In all the keyboards that use the split function, the split occurs in very specific physical keys (not in the tone), no matter what transpose the user sets in the keyboard.

I thought this was a pretty basic thing, but unfortunatelly the soundfont "protocol" does not allow that (I am not blaming Polyphone, as it looks like is a problem with the sounfont/MIDI inner workings).

If I am saying something stupid or if there is a workaround/hack, I will be glad to learn :)
Last Edit: 2 months 20 hours ago by batata004.
The administrator has disabled public write access.

Set parameters based on physical key being pressed 2 months 6 hours ago #6

  • csw900
  • csw900's Avatar
  • Offline
  • Senior Member
  • Posts: 59
  • Thank you received: 13
You can blame your keyboard for your problem. If it handles splits in the way you say then it should not be sending any out of range midi notes from its main transposable region.
I suggest you could try your keyboard with an organ which uses .sf2 sound fonts (such as my eplayOrgan). This will open up a whole new world of possibilities for you to experiment with.
csw900
csw900
Last Edit: 2 months 6 hours ago by csw900. Reason: bad layout
The administrator has disabled public write access.
The following user(s) said Thank You: batata004
  • Page:
  • 1
  • 2
Time to create page: 0.062 seconds