Welcome, Guest
Username: Password: Remember me

TOPIC: Polyphone 2.3 crashes if "exclusive class" is used

Polyphone 2.3 crashes if "exclusive class" is used 2 months 4 days ago #1

  • S. Christian Collins
  • S. Christian Collins's Avatar
  • Offline
  • Senior Member
  • Posts: 67
  • Thank you received: 25
"Exclusive class" is an instrument-level parameter most often used on hi-hats so that the closed hi-hat will mute the open hi-hat. However, if exclusive class is set for a sample (value of 1 or higher), Polyphone crashes when that sample is played.

Steps to reproduce:
1. Open the attached SoundFont in Polyphone 2.3 and select the preset.
2. Play any note.

Result: Crash

This happens using the Linux version (compiled from source) and Windows 7 (x64 installer). I haven't tested any other configurations.

This message has an attachment file.
Please log in or register to see it.

The administrator has disabled public write access.
The following user(s) said Thank You: Davy

Polyphone 2.3 crashes if "exclusive class" is used 2 months 4 days ago #2

  • ziyametedemircan
  • ziyametedemircan's Avatar
  • Offline
  • Premium Member
  • Posts: 141
  • Thank you received: 45
Confirmed.
Crashing occurs on any instrument (usually used in percussion) containing the Exclusive class.
The administrator has disabled public write access.
The following user(s) said Thank You: Davy

Polyphone 2.3 crashes if "exclusive class" is used 2 months 3 days ago #3

  • Davy
  • Davy's Avatar
  • Offline
  • Administrator
  • Organ enthusiast and creator of Polyphone
  • Posts: 412
  • Thank you received: 98
Fixed! Sorry for this. I'll prepare version 2.3.1 soon
The administrator has disabled public write access.
The following user(s) said Thank You: S. Christian Collins
Time to create page: 0.057 seconds