Welcome, Guest
Username: Password: Remember me

TOPIC: Polyphone 2.3 beta

Polyphone 2.3 beta 3 months 3 weeks ago #1

  • Davy
  • Davy's Avatar
  • Offline
  • Administrator
  • Organ enthusiast and creator of Polyphone
  • Posts: 412
  • Thank you received: 98
Hello everybody,

Polyphone 2.3 is now released in a beta state. I made installers only for Windows and Mac users for now.
www.polyphone-soundfonts.com/documents/6...4-polyphone-2-3-beta

The changelog should appear during the first start and if you find bugs... this thread would be the good place.

Regards,
Davy
The administrator has disabled public write access.

Polyphone 2.3 beta 3 months 3 weeks ago #2

  • ziyametedemircan
  • ziyametedemircan's Avatar
  • Offline
  • Premium Member
  • Posts: 141
  • Thank you received: 45
I don't think that the information values in this section are explanatory or explain the real effect of the entered value.



For example, for "pan", values between -500 and 500(*1) should be used as modulation values in the instrument part. However, when 50 is entered in the value input section, "Add from: -5 to 5" information is encountered. Increasing the value entry to 500 doesn't make any changes in the information section.

When the same modulator is applied in the preset part, the input values should be between -1000 and 1000 (*1), but there is no correct information here either. When 80 is entered, "-8 to 8" information is displayed, when 100 is entered, "-1 to 1" information is displayed, which is misleading.

*1: Testing how the internal synthesizer works with the help of ear and/or stereo VU-meter realizes that the unit values should be "0.1%".

PS: This is not specific to this version (2.3.0 beta), it was the case in previous version(s). I forgot to report every time, but I was able to write this during this beta release phase.

Thank you for your work on the new version of the Polyphone software.
The administrator has disabled public write access.
The following user(s) said Thank You: Davy

Polyphone 2.3 beta 3 months 3 weeks ago #3

  • ziyametedemircan
  • ziyametedemircan's Avatar
  • Offline
  • Premium Member
  • Posts: 141
  • Thank you received: 45
This is a new one.
In multi-instrument selection, parameter entry in Filter-cutoff doesn't work properly.
See the GIF I've attached.

I guess the forum is not playing the animated GIFs. I have attached it as a zip.
You can also play it by extracting it from the zip and dragging it to the browser.
Attachments:
Last Edit: 3 months 3 weeks ago by ziyametedemircan. Reason: animated GIF problem
The administrator has disabled public write access.
The following user(s) said Thank You: Davy

Polyphone 2.3 beta 3 months 3 weeks ago #4

  • Davy
  • Davy's Avatar
  • Offline
  • Administrator
  • Organ enthusiast and creator of Polyphone
  • Posts: 412
  • Thank you received: 98
Thank you for the feedback! You found 2 bugs.

The first one IS specific to the version 2.3 and is fixed.
However, the multiplication value is not directly linked to the unit. It can be expressed in tenths of a unit or even in an exponential scale if we follow the soundfont specifications. Values written to the right are only hints to know what range in the unit we can expect.

The editing issue in the table should be fixed.

Could you please install again the beta and test? I just updated the installer.
The administrator has disabled public write access.
The following user(s) said Thank You: ziyametedemircan

Polyphone 2.3 beta 3 months 3 weeks ago #5

  • ziyametedemircan
  • ziyametedemircan's Avatar
  • Offline
  • Premium Member
  • Posts: 141
  • Thank you received: 45
Congratulations, Both seem to be fixed.

(By the way, I'm not specifically trying to find bugs. They caught my eye because I sensed something strange in daily use. Since no one else has reported anything but me, there is probably no second person who uses this software as much on a daily basis as I do :))
The administrator has disabled public write access.

Polyphone 2.3 beta 3 months 3 weeks ago #6

  • ziyametedemircan
  • ziyametedemircan's Avatar
  • Offline
  • Premium Member
  • Posts: 141
  • Thank you received: 45
By the way, I'd like to mention something else that might be useful: This is both a bug and a feature request.

Let's say we expand an instrument down to see its samples. Here, we can select samples in different orders (not consecutive ones) separately with the mouse while holding down the Ctrl key. Let's say the second, fourth, fifth, and ninth samples.
But while holding down the Ctrl key, we cannot navigate with the up/down arrow keys of the keyboard and we cannot make selections by pressing the space bar. This causes us to direct our right hand from the keyboard to the mouse.



Is this due to QT? Or is there such a feature in QT's select/list window. Maybe it's turned off by default but needs to be turned on specifically? I do not know.

If this message does not comply with bug reports, it can be moved to feature request.
The administrator has disabled public write access.
Time to create page: 0.065 seconds
Cron Job Starts