Welcome, Guest
Username: Password: Remember me

TOPIC: After replacing stereo samples they're mono!!!

After replacing stereo samples they're mono!!! 8 months 17 hours ago #1

  • Michael
  • Michael's Avatar
  • Offline
  • Senior Member
  • Posts: 55
  • Thank you received: 10
Because I noticed other people dealt with the same problem as I think it can be helpful to create this separate topic to share you some information about it and what you can do to prevent the stereo sound will become monophonic.


Stereo sound contain two channels and within soundfonts those channels are separated as individual samples. With Polyphone you can link them though, which gives you benefits like the loop points and the tuning will be the same with both samples and also when assigning them to an instrument they will be panned automatically. If you do not want that to happen. Just simply unlink them so they will behave like separate monophonic samples. Linking or unlinking can be done by first selecting the samples in the Samples section, then clicking on the toolbox (the box-icon) and you’ll find the options “Find a link” and “Unlink”

The samples of soundfonts can be exported, which you can do in the same Toolbox by clicking on “WAV export”. When the channels of stereo-samples are linked Polyphone exports them as stereo WAV-files. When they’re not linked the left and right channels will be exported separately as monophonic WAV-files.

The exported sounds can be imported as well. When they’ve got the same name as the samples already in the soundfont you have the option to replace them or import them as a copy. This comes in handy when you want to use an external audio editor to edit the samples. When you choose to replace the original ones the new ones will automatically be assigned to its existing instrument with the same parameters. However…

in the case of importing stereo-samples something goes wrong, because then the left channel replaces both the left and right channel, resulting in the right channel will be lost!

—————

There’s a simple trick you can prevent this will occur. First create an entirely new soundfont with Polyphone. There you will import the new samples. After that copy the samples to the clipboard (select the imported samples, click on the right button of your mouse and select “Copy”). Then go back to the Samples section of the soundfont where you want to replace the samples, click again with your right mouse button and select “Paste”.

Now you can replace the stereo samples without losing the right channel.
The administrator has disabled public write access.
The following user(s) said Thank You: siebenhirter
Time to create page: 0.041 seconds