Welcome, Guest
Username: Password: Remember me

TOPIC: Required STK version?

Required STK version? 1 month 15 hours ago #1

  • mirabilos
  • mirabilos's Avatar
  • Offline
  • New Member
  • Debian Developer
  • Posts: 10
  • Thank you received: 2
For backporting within Debian and *buntu, I’m wondering what’s the minimum STK version required?

Debian buster and stretch have 4.5.2, as does *buntu bionic.

*buntu xenial has 4.5.0, trusty 4.4.4, precise 4.4.3 (but I really hope nobody runs precise any more, even trusty is unsupported enough to lack the recent sudo fix but I know that a *lot* of multimedia distros are trusty-based.

These are all libstk0-dev.

Debian bullseye/sid and *buntu focal have 4.6.1 (libstk-dev), and this is what I primarily package for. Due to its presence, I cannot use the bundled STK as Debian Policy mandates we use the distro-wide versions (mostly so that security fixes etc. are applied centrally and there is no code duplication and embedding).
The administrator has disabled public write access.

Required STK version? 2 weeks 2 days ago #2

  • mirabilos
  • mirabilos's Avatar
  • Offline
  • New Member
  • Debian Developer
  • Posts: 10
  • Thank you received: 2
It seems to work with buster’s but the application is still very crashy.

I’m trying to get the fix for bugs.debian.org/cgi-bin/bugreport.cgi?bug=944509 included into buster.
The administrator has disabled public write access.

Required STK version? 2 weeks 2 days ago #3

  • mirabilos
  • mirabilos's Avatar
  • Offline
  • New Member
  • Debian Developer
  • Posts: 10
  • Thank you received: 2
OK, this works for Debian but not for *buntu — bionic (18.04 LTS) only has qcustomplot 1.3 which is too old.

Oh well, ze la Vieh, the PPA launchpad.net/~mirabilos/+archive/ubuntu/ppa has it for focal (20.04 LTS) and Debian backports will do the rest.
The administrator has disabled public write access.
Time to create page: 0.065 seconds