Welcome, Guest
Username: Password: Remember me

TOPIC: Can't build on Raspberry Pi 4 / Raspbian Buster

Can't build on Raspberry Pi 4 / Raspbian Buster 5 days 10 hours ago #1

  • Magnus
  • Magnus's Avatar
  • Offline
  • New Member
  • Posts: 2
Hi all,
I've downloaded the binary for 2.2 and followed the instructions in the readme, but I get an error running qmake:
g++: error: unrecognized command line option '-mfpath=387'

Is there any way to get this running on Arm?

Thanks!
Last Edit: 5 days 10 hours ago by Magnus.
The administrator has disabled public write access.

Can't build on Raspberry Pi 4 / Raspbian Buster 5 days 6 hours ago #2

  • Magnus
  • Magnus's Avatar
  • Offline
  • New Member
  • Posts: 2
I got it! Not sure how exactly, but I’ll share what I tried at least.

So:
qmake -qt5 && make
per the readme, was failing in the make part with the
g++: error: unrecognized command line option '-mfpath=387'
error I mentioned above.

I tried going into the Makefile and just taking out all occurrences of
-mfpmath=387
(there were 7). I then tried ‘make’ again, and actually got further into compiling, but still ended up with an error. This time it was the
Chorus.h: No such file or directory
error (mentioned in this post). I tried the solution listed there, which was to uncomment the line
DEFINES += USE_LOCAL_STK
in the polyphone.pro file. I ran ‘make’ again, and again got a bit further in compiling, but hit another error. This time it was
fatal error: jack.h: No such file or directory
Basically my experience was going the same as in the thread mentioned above. I then went to try Knut Petersen’s solution from that thread, to manually add
-isystem /usr/include/stk -isystem /usr/include/jack
add the end of INCPATH in Makefile – except that when I got in there, I saw that both paths were already listed. I double checked that these folders were in fact at usr/include/ in my system, and they are. So I went a little further into polyphone.pro, to the section starting with
unix:!macx {
and where it says
INCLUDEPATH += $$PREFIX/include/jack
I changed it to
INCLUDEPATH += /usr/include/jack
I then ran make again, and it worked. Interestingly, because at some point I guess I ran qmake again, it looks like the Makefile once again had the
-mfpmath=387
flags in it, and yet I hit no errors for that.

Also, the executable ended up in the sources/bin/ folder, not in a directory called ‘RELEASE’ as per the readme file.

* * *

TL;DR

If trying to compile for Raspberry Pi, in the polyphone.pro file, uncomment
DEFINES += USE_LOCAL_STK
Then go down to the section starting with
unix:!macx {
and make sure the INCLUDEPATH += path is set to where your jack folder is. By default it is pointing to
$$PREFIX/include/jack
(which is /usr/local/include/jack), but try
INCLUDEPATH += /usr/include/jack
.

If you still get the -mfpmath error, you can try taking mentions of it out of the Makefile; I may or may not have done that at the time that I successfully built it.

I should mention that I haven't really tested out the program other than launching it, but it looks correct. Also, sorry for the long post, wanted to be thorough. I am very much looking forward to using this software, thanks Davy!
The administrator has disabled public write access.
Time to create page: 0.111 seconds
Cron Job Starts