Welcome, Guest
Username: Password: Remember me

TOPIC: Polyphone + ASIO4All. Closing Polyphone bgprocess

Polyphone + ASIO4All. Closing Polyphone bgprocess 1 year 1 month ago #1

  • John Schumacher
  • John Schumacher's Avatar
  • Offline
  • New Member
  • Posts: 2
Polyphone 2.01
OS - Windows 10
Sound Device - Realtek (nothing fancy)
Using ASIO4All v2.14

Firstly, Polyphone is amazing. I have been ripping MIDI and SF2s from games, as well as sampling my own instruments with my TASCAM and turning them into SF2s. Polyphone has been with me every step of the way.

Recently, I purchased a MalletKat, and have been playing around with it. Polyphone has also been great to take the MIDI and apply whatever soundfont I have selected. ASIO4All provides a dedicated link to the sound driver to allow for low-latency sound generation when I hit the MalletKat. Great - no problems there besides a few scattered crashes which I can live with.

However, when I exited Polyphone, it looked like ASIO4All was still grabbing my Realtek sound device and preventing other programs from producing sound. I figured out that Polyphone, after I closed it, was lingering around as a background process, as seen in my Task Manager. After force-killing that process, ASIO4All was released and other programs could use the sound driver.

Does anyone know why my Polyphone process would still live after closing it? I wonder if this is entirely related to ASIO4All...

Anyway, not a huge issue now that I know how to really kill Polyphone (close both the program and kill the lingering background process)
Thanks!


*Edit - after some quick testing, it does appear to be behavior related to ASIO4All. When I configure Polyphone to use use Realtek, then it doesn't linger as a background process after being closed. I wonder if Polyphone doesn't want to close out with ASIO4All still hanging around.
Last Edit: 1 year 1 month ago by John Schumacher.
The administrator has disabled public write access.

Polyphone + ASIO4All. Closing Polyphone bgprocess 11 months 3 weeks ago #2

  • Davy
  • Davy's Avatar
  • Offline
  • Administrator
  • Organ enthusiast and creator of Polyphone
  • Posts: 343
  • Thank you received: 83
Is it possible to try version 2.1 beta? I tried and I cannot reproduce the bug.
The administrator has disabled public write access.
The following user(s) said Thank You: John Schumacher

Polyphone + ASIO4All. Closing Polyphone bgprocess 11 months 2 weeks ago #3

  • John Schumacher
  • John Schumacher's Avatar
  • Offline
  • New Member
  • Posts: 2
Interesting enough, it does not appear to be occurring in the 2.1 beta. I appeared to have been running 2.01 prior to that, so it's entirely possible it was fixed between then or something changed on my end. Thanks for taking the time to investigate this!
The administrator has disabled public write access.
Time to create page: 0.062 seconds
Cron Job Starts