Welcome, Guest
Username: Password: Remember me

TOPIC: modulators have no effect

modulators have no effect 3 weeks 4 days ago #1

  • Joachim Schneider
  • Joachim Schneider's Avatar
  • Offline
  • New Member
  • Posts: 2
i'm new here in the forum so: HELLO! :) .... and i'm a beginner in working with soundfonts and polyphone. i tried to find out some of the functions and i stuck with the modulators. i set up a soundfont with some drumsamples and tried to get global modulators for amp env attack and amp env release to work. via the inbuilt virtual keyboard in polyphone, i can here the effect of controlchanges of the cc controllers (in this case 17 and 18). but when i'm in my daw (ardour) and open it with calf fluidsynth, linuxsampler or carla (or whatver..) and try to automate these cc controllers, there is no audible effect noticeable. also not for other parameters like cutoff frequency or whatever, tried many parameters, which worked only within polyphone itself. can someone help? thanks in advance for your help! :-)


ps: i'm on linux mint 19.2, polyphone 2.1.0, formats tried: sf2,sf3, sfz (in carla).
attached an image of the setup in polyphone

sorry for my poor english.... :unsure:
Attachments:
Last Edit: 3 weeks 4 days ago by Joachim Schneider.
The administrator has disabled public write access.

modulators have no effect 3 weeks 2 days ago #2

  • S. Christian Collins
  • S. Christian Collins's Avatar
  • Offline
  • Senior Member
  • Posts: 51
  • Thank you received: 20
Linuxsampler doesn't support modulators, but they should work in FluidSynth. Try re-downloading and installing the latest version of Polyphone. The program has been updated recently to fix a bug saving modulators, though the version number is still the same. After re-installing Polyphone, load up your SoundFont and re-save it. See if that fixes it.
The administrator has disabled public write access.
The following user(s) said Thank You: Joachim Schneider

modulators have no effect 3 weeks 1 day ago #3

  • Joachim Schneider
  • Joachim Schneider's Avatar
  • Offline
  • New Member
  • Posts: 2
For some reason it now works, after i recorded a modulation curve in ardour on the corresponding cc controllers. Seems to be an Ardour issue... Anyway, thanks for your reply! :-)
The administrator has disabled public write access.
Time to create page: 0.043 seconds