Welcome, Guest
Username: Password: Remember me

TOPIC: QT can not build polyphone project sucessfully.

QT can not build polyphone project sucessfully. 2 weeks 4 days ago #1

  • jeremylei
  • jeremylei's Avatar
  • Offline
  • New Member
  • Posts: 2
:(
I have been following the Documentation steps of built polyphone project with QT, but when the QT built project, there are some errors coming,

C:\Qt\Qt5.8.0ei17767002675\Tools\mingw530_32\i686-w64-mingw32\include\c++\bits\c++0x_warning.h:32: error: #error This file requires compiler and library support for the ISO C++ 2011 standard. This support is currently experimental, and must be enabled with the -std=c++11 or -std=gnu++11 compiler options.
#error This file requires compiler and library support for the \
^

I need somebody who can figure out the problem sincerely, thanks.
The administrator has disabled public write access.

QT can not build polyphone project sucessfully. 2 weeks 3 days ago #2

  • Davy
  • Davy's Avatar
  • Offline
  • Administrator
  • Organ enthusiast and creator of Polyphone
  • Posts: 234
  • Thank you received: 53
Hello you need the visual C++ compiler, not mingw (this is in the option when you install Qt)
Regards,
Davy
The administrator has disabled public write access.
The following user(s) said Thank You: jeremylei

QT can not build polyphone project sucessfully. 1 week 4 days ago #3

  • jeremylei
  • jeremylei's Avatar
  • Offline
  • New Member
  • Posts: 2
Thank you for your advice,but I still can not build the project successful in Windows Operation System. I think it's important to configure the
compiler environment exactly so that QT can build the project successfully.
Last Edit: 1 week 4 days ago by jeremylei.
The administrator has disabled public write access.
Time to create page: 0.050 seconds