Welcome, Guest
Username: Password: Remember me

TOPIC: Polyphone 2.0 Crashes with FlexASIO 1.4 installed

Polyphone 2.0 Crashes with FlexASIO 1.4 installed 2 weeks 2 days ago #1

  • Arvind
  • Arvind's Avatar
  • Offline
  • New Member
  • Posts: 1
Hello,
I've been using Polyphone for a month or two now and I love it! However today I started it up for the first time in a couple days and I got a crash on startup. I uninstalled and reinstalled the 64bit version several times. I also cleared out the registry key by hand and even tried installing the 32bit version to no avail. I checked the Windows error logs and saw the error may be caused by ucrtbase.DLL Which has been responsible for quite a few application crashes as it is tied to the MS Visual C runtimes.

I tried repairing all versions of my MS Visual C runtimes but the problem persists. I finally ran the MS Visual Studio Debugger and even though Polyphone.exe was built without debug information as it is in release mode. I saw the DLL dependency tree that was loaded and spotted the DLL for FlexASIO which I happened to install only today. I uninstalled FlexASIO and Polyphone started working again. As a developer I know this is probably not a problem with Polyphone.exe at all but I thought I would post here as well as on the FlexASIO development repo to assist both sets of developers just in case. I hope this post proves useful to someone.
I am loath to uninstall FlexASIO permanently since it works wonderfully well with my production chain and I need it for some of my software. Looks like I'll be juggling installs/uninstalls for a while though :-)

OS: Win7/64bit
Interaction issue with:=: 64bit and 32bit Versions of Polyphone. I even tried version 1.9 and has the same issue.
Last Edit: 2 weeks 2 days ago by Arvind. Reason: Solved crash cause myself.
The administrator has disabled public write access.

Polyphone 2.0 Crashes with FlexASIO 1.4 installed 2 weeks 1 day ago #2

  • ziyametedemircan
  • ziyametedemircan's Avatar
  • Offline
  • Junior Member
  • Posts: 36
  • Thank you received: 10
Try this:
Open the Polyphone software folder, (in Program Files or Program Files (x86)
Rename the portaudio(NN) dll in the Polyphone folder. (eg: dllx)

Then; Open the Flexasio software folder, (in Program Files or Program Files (x86)
copy the Portaudio(NN) dll there into the Polyphone software's folder.
Make sure both are x64 or x86.

I hope it helps.
Last Edit: 2 weeks 1 day ago by ziyametedemircan.
The administrator has disabled public write access.
Time to create page: 0.081 seconds