Welcome, Guest
Username: Password: Remember me
  • Page:
  • 1
  • 2

TOPIC: Polyphone bug samples loop coarse

Polyphone bug samples loop coarse 5 months 1 week ago #1

  • Dan
  • Dan's Avatar
  • Offline
  • New Member
  • Posts: 6
Hello,

If you have one instrument zone, with some loop start/stop offset

then you save the instrument in polyphone

It transform this into the samples loop zone

so it remove the generators #2 and #3

but it does not remove the generators #45 and #50 (coarse values) !!!!!!!
The administrator has disabled public write access.

Polyphone bug samples loop coarse 2 months 11 hours ago #2

  • Dan
  • Dan's Avatar
  • Offline
  • New Member
  • Posts: 6
Not sure if Davy is reading this bug, and if it has been corrected on the new beta ?
I can't use Polyphone for now if it kill my SF2 collection changing the loop start/stop incorrectly
The administrator has disabled public write access.

Polyphone bug samples loop coarse 2 months 8 hours ago #3

  • Davy
  • Davy's Avatar
  • Offline
  • Administrator
  • Organ enthusiast and creator of Polyphone
  • Posts: 321
  • Thank you received: 76
Hello I did the following:
* open a soundfont
* at the instrument level, add a different value in the 4 possible offsets (loop / sample start / end offset)
* save the soundfont
* close the soundfont
* reopen the soundfont

I got the same values as expected. Maybe you mentioned something else?

Regards,
Davy
The administrator has disabled public write access.

Polyphone bug samples loop coarse 2 months 8 hours ago #4

  • Dan
  • Dan's Avatar
  • Offline
  • New Member
  • Posts: 6
mmm... the problem is if there is NOT loop informations in the samples themself
When saving, you fill the loop information from the instrument zone to the sample zone
but you don't remove the coase values of the instrument zone
And as you know, they are OFFSETS, so the player need to addition the loop values of the sample zone + the info of the instrument zone
The administrator has disabled public write access.

Polyphone bug samples loop coarse 2 months 4 hours ago #5

  • Davy
  • Davy's Avatar
  • Offline
  • Administrator
  • Organ enthusiast and creator of Polyphone
  • Posts: 321
  • Thank you received: 76
I cannot reproduce the bug. Here is what I did:

* I created a new soundfont and added a sample with no loop inside,
* I created an instrument with one division containing the sample,
* 4 different values have been set in the offsets,
* I saved, closed, reopened,
* values are still correct and no loop at the sample level.

Please describe the process for reproducing the bug, this is still not very clear.

Regards,
Davy
The administrator has disabled public write access.

Polyphone bug samples loop coarse 2 months 2 hours ago #6

  • Dan
  • Dan's Avatar
  • Offline
  • New Member
  • Posts: 6
* create a new soundfont and add a sample. Uncheck "En Boucle" and set the loop point start and stop at 0
* created an instrument with one division containing the sample,
* add 2 different values for the loop offsets start and stop, exp 5000 and 10000
* save

Go to the sample screen, you will see "en boucle" back again, and values back from 0 to end of sample
The administrator has disabled public write access.
  • Page:
  • 1
  • 2
Time to create page: 0.048 seconds