Welcome, Guest
Username: Password: Remember me

TOPIC: bugs when deleting divisions

bugs when deleting divisions 3 weeks 6 days ago #1

  • S. Christian Collins
  • S. Christian Collins's Avatar
  • Offline
  • Junior Member
  • Posts: 32
  • Thank you received: 10
I have discovered two bugs that you can see demonstrated in the attached video.

Bug #1: Deleting multiple divisions at once jumps the tree view all the way to the top.

Steps to reproduce:
1. Open a SoundFont with a lot of instruments and presets (such as a GM bank).
2. Scroll down the tree view to find an instrument or preset with many divisions.
3. Click on a division, then shift-click another division to select multiple divisions.
4. Press the delete key (or right-click -> delete).

Result: the tree view jumps all the way to the top.
Expected result: the tree view should remain at the current instrument/preset.

Bug #2: After changing division sort order, deleted divisions appear as "..."

Steps to reproduce:
1. Open a SoundFont
2. In settings, change the division sort order. It doesn't seem to matter which option is selected, but I typically choose "none".
3. Expand an instrument or preset in the tree view and delete one or more of its divisions.

Result: the division name is replaced with "..." and remains in the tree view.
Expected result: the division should have been deleted and its space in the tree view eliminated.

I am running Polyphone 2.0 compiled in KDE neon 5.14 (based on Ubuntu 18.04).

This message has an attachment file.
Please log in or register to see it.

Last Edit: 3 weeks 6 days ago by S. Christian Collins.
The administrator has disabled public write access.
The following user(s) said Thank You: Davy

bugs when deleting divisions 3 weeks 6 days ago #2

  • Davy
  • Davy's Avatar
  • Offline
  • Administrator
  • Organ enthusiast and creator of Polyphone
  • Posts: 227
  • Thank you received: 48
Fixed
The administrator has disabled public write access.
Time to create page: 0.054 seconds