Welcome, Guest
Username: Password: Remember me

TOPIC: regression: sample offset values are incorrect

regression: sample offset values are incorrect 3 weeks 6 days ago #1

  • S. Christian Collins
  • S. Christian Collins's Avatar
  • Offline
  • Junior Member
  • Posts: 32
  • Thank you received: 10
Polyphone 2.0 displays sample start offset values > 32767 and sample end offset values < -32768 incorrectly. Polyphone 1.9 displays these values correctly.

The instrument in the attached SoundFont has samples with the following offsets:

Sample start: 1000, 5000, 10000, 20000, 32767, 32768, 32769, 50000, 100000
Sample end: -100000, -50000, -32769, -32768, -32767, -20000, -10000, -5000, -1000

...and Polyphone 1.9 correctly displays these values.
Polyphone 2.0 shows these values instead (erroneous numbers are in red):

Sample start: 1000, 5000, 10000, 20000, 32767, -32768, -32767, -15536, -31072
Sample end: 31072, 15536, 32767, -32768, -32676, -20000, -10000, -5000, -1000

It would seem that perhaps Polyphone 2.0 is not correctly factoring the coarse offset value (startAddrsCoarseOffset, endAddrsCoarseOffset) into the total offset value.

This message has an attachment file.
Please log in or register to see it.

Last Edit: 3 weeks 6 days ago by S. Christian Collins.
The administrator has disabled public write access.
The following user(s) said Thank You: Davy

regression: sample offset values are incorrect 3 weeks 6 days ago #2

  • Davy
  • Davy's Avatar
  • Offline
  • Administrator
  • Organ enthusiast and creator of Polyphone
  • Posts: 227
  • Thank you received: 48
That was a major bug. Thank you!
It's fixed
The administrator has disabled public write access.
Time to create page: 0.044 seconds