Welcome, Guest
Username: Password: Remember me
  • Page:
  • 1
  • 2

TOPIC: Compiling under Ubuntu 18.04

Compiling under Ubuntu 18.04 1 year 4 months ago #7

  • GonzoB
  • GonzoB's Avatar
  • Offline
  • New Member
  • Posts: 4
Thanks, Davy.

I did that, then got this:
pages/graphicsviewenvelop.cpp:323:18: error: ‘class QVector<double>’ has no member named ‘length’
         if (data.length() - currentSmplPos < nbRead)
                  ^~~~~~

This error repeats a number of times in the lines following the above. Is there some declaration missing?

Gonzo
The administrator has disabled public write access.

Compiling under Ubuntu 18.04 1 year 4 months ago #8

  • Davy
  • Davy's Avatar
  • Offline
  • Administrator
  • Organ enthusiast and creator of Polyphone
  • Posts: 340
  • Thank you received: 82
It seems that this thread is already answering this issue please see
www.polyphone-soundfonts.com/en/forum/su...der-ubuntu-18-04#702
The administrator has disabled public write access.

Compiling under Ubuntu 18.04 1 year 4 months ago #9

  • GonzoB
  • GonzoB's Avatar
  • Offline
  • New Member
  • Posts: 4
Thanks, Davy.

I had actually read the thread, and the other recent one on this subject, and I have tried all the suggestions. I am obviously missing something.

I loaded Qt Creator, and it came up with the same errors.

So now neither Swami nor Polyphone runs on the latest Ubuntu. I have no soundfont editor to use with Fluidsynth.

Gonzo
The administrator has disabled public write access.

Compiling under Ubuntu 18.04 1 year 4 months ago #10

  • John Lemcke
  • John Lemcke's Avatar
  • Offline
  • New Member
  • Posts: 4
  • Thank you received: 1
I'm pretty sure this is a Qt4 vs. Qt5 issue. If you have a look at

Qt 4.8 QVector docs
and
Qt 5.11 QVector docs

you will see that the length() method was not available in Qt4.

So it seems that you are still linking against the Qt4 libraries. Have another look at my previous post, there may be some other packages that you have installed that need to be removed, or perhaps an 'apt-get purge libqt4-dev' is needed.

BTW: I am not a Qt expert, so there may be some Qt4/Qt5 configuration that I am missing, but what I posted earlier worked for me. YMMV

Have Fun,
JL
The administrator has disabled public write access.

Compiling under Ubuntu 18.04 1 year 4 months ago #11

  • GonzoB
  • GonzoB's Avatar
  • Offline
  • New Member
  • Posts: 4
Thanks all.

I went back to scratch and redid all your steps John, and I had to re-create a link from /usr/bin/qtmake to the QT5 executable. Now it works. Obviously I had something left over from the original README.

Note that you can't (well, I can't) double-click the executable from the desktop and make it run. It only works from the command line or via a launcher.

Note also that those edits for _qscrollX, etc are not necessary.

Thanks for all the help.

Gonzo
Last Edit: 1 year 4 months ago by GonzoB.
The administrator has disabled public write access.

Compiling under Ubuntu 18.04 1 year 2 months ago #12

  • Alexander Hanysz
  • Alexander Hanysz's Avatar
  • Offline
  • New Member
  • Posts: 1
Thanks John Lemcke, this worked for me. Just one comment: there's no need to install libqt4-dev. You can link to the correct libraries by replacing the "qmake" command with "qmake -qt=qt5"
The administrator has disabled public write access.
  • Page:
  • 1
  • 2
Time to create page: 0.140 seconds